[Webkit-unassigned] [Bug 22479] Consider renaming to 'deepCopy' the 'copy' methods that perform a deep copy

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 25 13:44:08 PST 2008


------- Comment #4 from ggaren at apple.com  2008-11-25 13:44 PDT -------
> I think that StringImpl::deepCopy() would be a misnomer (and a comment in
> StringImpl.h is already slightly misleading). 

Why do you think the comment is misleading? Because the reference count doesn't
get copied?

> Also, moving an immutable object
> across threads doesn't necessarily involve making a deep copy - e.g. members
> that are ThreadSafeShared can be shallow-copied.

If the sole purpose of these functions is to move objects across threads, and
they should optimize to copy ThreadSafeShared data in a shallow way, then a
name like "threadSafeCopy" would be better. What do you think of that?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list