[Webkit-unassigned] [Bug 22479] Consider renaming to 'deepCopy' the 'copy' methods that perform a deep copy

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 25 06:27:28 PST 2008


ap at webkit.org changed:

           What    |Removed                     |Added
                 CC|                            |ap at webkit.org

------- Comment #3 from ap at webkit.org  2008-11-25 06:27 PDT -------
I think that StringImpl::deepCopy() would be a misnomer (and a comment in
StringImpl.h is already slightly misleading). Also, moving an immutable object
across threads doesn't necessarily involve making a deep copy - e.g. members
that are ThreadSafeShared can be shallow-copied.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list