[Webkit-unassigned] [Bug 20031] Implement ES 3.1 JSON object

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 15 02:46:51 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=20031





------- Comment #9 from ap at webkit.org  2008-07-15 02:46 PDT -------
(From update of attachment 22271)
I didn't attempt to really review this (and the patch is not up for review
anyway :) ), but here are some comments I had while skimming over.

+static inline void ws(State* state)

This definitely needs a better name, and ideally, should share code with other
isWhitespace/skipWhitespace functions we have (e.g. Lexer::isWhiteSpace,
isASCIIWhitespace).

+    return paddedLiteral(state, L'[');

On the Mac, wchar_t is 32-bit, so we cannot use this type and its associated
compiler features.

+    static const UChar falseLiteral[] = { 'f', 'a', 'l', 's', 'e', '\0' };

I'm not 100% sure, but I suspect that this array may be initialized at runtime,
not compile time. If so, this initialization is not thread safe.

+        while(digit(state))

There should be a space after while.

A general question: what is the reason for writing a custom parser, and not
using bison?


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list