[Webkit-unassigned] [Bug 22664] Rename and review uses of parseURL()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 4 17:01:40 PST 2008


------- Comment #2 from darin at apple.com  2008-12-04 17:01 PDT -------
(In reply to comment #1)
> I think parseURL() should be renamed to parseCSSURL() (or parseURLForCSS()) and
> moved to be in KURL.h/KURL.cpp. (That gets rid of CSSHelper.cpp, leaving only
> CSSHelper.h with a few constants.)

I agree that parseCSSURL is a good name. But I don't think KURL.h is the header
for this. It's not about URL handling, but rather about the CSS syntax for URL
properties. I think the right header for this would be CSSParser.h.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list