[Webkit-unassigned] [Bug 15221] Make the FileSystemChooserGdk implementation properly convert the WebCore::String presentation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 17 08:09:24 PDT 2007


freyther at handhelds.org changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED

------- Comment #5 from freyther at handhelds.org  2007-09-17 08:09 PDT -------
(In reply to comment #4)
> (From update of attachment 16304 [edit])
> I think "convertToStringByAdoptingTheFilesystemRepresentation" may be a little
> bit wordy.  At the least, I think "The" does not add anything.  Elsewhere we
> also treat "filesystem" as two words.  Perhaps
> "stringWithFileSystemRepresentation" would be a better name?
> "filenameSystem" also feels backwards.  "systemFilename" reads better to me.
> Other than these naming niggles, r=me.

Oops, I landed that without reading that part. I agree with systemFilename and
will do a fixup (without going through review) but the function name is
difficult as it takes ownership of the systemFilename and we wanted to have
that inside the name.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list