[Webkit-unassigned] [Bug 15691] New: [GTK] Public API does not follow GTK+ conventions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 25 12:10:03 PDT 2007


           Summary: [GTK] Public API does not follow GTK+ conventions
           Product: WebKit
           Version: 523.x+ (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: Gtk
          Severity: Major
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: alp at atoker.com

There is evidence that the WebKitPage class should instead be named *View to
match GTK+ convention of widgets to be added to scrolled containers eg.
TreeView and TextView.

It may also be prudent to follow GTK+ coding style in classes under
WebKit/gtk/Api/ and perhaps WebKitSupport since its very much the convention
when you are defining GObject classes in boilerplate-heavy C code.

We may also want to introduce much of the new API in one go to avoid the
situation where people add bits and pieces to scratch an itch, making it
inconsistent. To this end, we may want to borrow from/adopt:


I'm not entirely convinced by that API either. The delegate classes would need
to go. Some of the entry point names are also rather lengthy.

We need to discuss these issues so we can move forward with a public API for
WebKit/Gtk+ that can be supported in the long term, or even recommend for use
in applications at all.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list