[Webkit-unassigned] [Bug 15299] GTK: ChromeClientGtk.cpp does not implement mouseDidMoveOverElement()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 7 00:55:28 PDT 2007


jmalonzo at gmail.com changed:

           What    |Removed                     |Added
  Attachment #16569|0                           |1
        is obsolete|                            |
  Attachment #16572|                            |review?
               Flag|                            |

------- Comment #23 from jmalonzo at gmail.com  2007-10-07 00:55 PDT -------
Created an attachment (id=16572)
 --> (http://bugs.webkit.org/attachment.cgi?id=16572&action=view)
Fix signal not emitted when hovering on links in succession - update2

(In reply to comment #22)
> m_hoveredLink.isEmpty())) {
> The m_hoveredLink.isEmpty() part of this check is superfluous. If
> m_hoveredLink.isEmpty() will return true, then so will url != m_hoveredLink
> (since we already checked !url.isEmpty()).

Hi! Yeah you're right. Fixed in the updated patch.

> +        m_hoveredLink = "";
> It would be better to say:
> m_hoveredLink = KURL();


> I think it would be good to rename m_hoveredLink to m_hoveredLinkURL.


> r- so we can get that redundant check in the if statement out of here.

Done. Thank you.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list