[Webkit-unassigned] [Bug 15299] GTK: ChromeClientGtk.cpp does not implement mouseDidMoveOverElement()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 6 23:26:24 PDT 2007


aroben at apple.com changed:

           What    |Removed                     |Added
  Attachment #16569|review?                     |review-
               Flag|                            |

------- Comment #22 from aroben at apple.com  2007-10-06 23:26 PDT -------
(From update of attachment 16569)
+        if (!url.isEmpty() && (url != m_hoveredLink ||
m_hoveredLink.isEmpty())) {

The m_hoveredLink.isEmpty() part of this check is superfluous. If
m_hoveredLink.isEmpty() will return true, then so will url != m_hoveredLink
(since we already checked !url.isEmpty()).

+        m_hoveredLink = "";

It would be better to say:

m_hoveredLink = KURL();

I think it would be good to rename m_hoveredLink to m_hoveredLinkURL.

r- so we can get that redundant check in the if statement out of here.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list