[Webkit-unassigned] [Bug 15357] New: The Gtk+ WebKit API namespace (webkit_gtk) is ugly

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 3 03:23:30 PDT 2007


           Summary: The Gtk+ WebKit API namespace (webkit_gtk) is ugly
           Product: WebKit
           Version: 522+ (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: Gtk
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: alp at atoker.com

The naming convention that has arisen for the Gtk+ WebKit public API is not
very elegant or conventional.

eg. webkit_gtk_frame_new()

The _gtk component is redundant and should be removed.

eg. webkit_frame_new()

It may even be an idea to reduce webkit_ to web_ as suggested by andersca...

eg. web_frame_new()

This makes the API less verbose and also self-describing in a cute kind of way
-- everyone can imagine what a "Web Frame" is.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list