[Webkit-unassigned] [Bug 14740] Hierarchical layout tests and platform organization

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 9 19:48:39 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=14740





------- Comment #8 from aroben at apple.com  2007-08-09 19:48 PDT -------
(From update of attachment 15892)
+if (isTiger()) {
+    $platform = "mac-leopard";
+} elsif (isLeopard()) {
+    $platform = "mac";

I think it should be:

if (isLeopard()) {
   $platform = "mac-leopard";
} elsif (isOSX()) {
   $platform = "mac";
}...

+my $platformTestDirectory = catdir($testDirectory, 'platform');
+$platformTestDirectory = catdir($platformTestDirectory, $platform);

You can combine these lines into one:

my $platformTestDirectory = catdir($textDirectory, 'platform', $platform);

+sub platformDirForTest($)

I think this could use a better name -- perhaps "directoryForNewResults" or
something like that. Then we might want to rename "expectedDirectoryForText" to
"directoryForExistingResults".

+    my @paths = split('/', $test);

You should use File::Spec->splitpath here:

my (undef, @paths, undef) = File::Spec->splitpath($test);

(I'm not sure if the leading '/' is still needed in this case).


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list