[Webkit-unassigned] [Bug 7724] New: Minor refactoring to HTMLParser::handleError() to remove duplicate code

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Sat Mar 11 14:14:33 PST 2006


http://bugzilla.opendarwin.org/show_bug.cgi?id=7724

           Summary: Minor refactoring to HTMLParser::handleError() to remove
                    duplicate code
           Product: WebKit
           Version: 420+ (nightly)
          Platform: Macintosh
        OS/Version: Mac OS X 10.4
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML DOM
        AssignedTo: webkit-unassigned at opendarwin.org
        ReportedBy: ddkilzer at kilzer.net


This code could be consolidated:

        // ....
        } else if (h->hasLocalName(titleTag)) {
            popBlock(currentTagName);
            handled = true;
        // ....
        } else if (h->hasLocalName(dlTag) || h->hasLocalName(dtTag)) {
            popBlock(currentTagName);
            handled = true;
        // ....
        } else if (h->hasLocalName(addressTag)) {
            popBlock(currentTagName);
            handled = true;
        // ....
        } else if (h->hasLocalName(fontTag)) {
            popBlock(currentTagName);
            handled = true;
        // ....

However, tests should be written for this code since commenting out the
duplicate code did not cause any tests to break.


-- 
Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list