[Webkit-unassigned] [Bug 9561] REGRESSION: Content property on :before of button causes hang on click or hover

bugzilla-daemon at opendarwin.org bugzilla-daemon at opendarwin.org
Sun Jun 25 10:31:25 PDT 2006


------- Comment #8 from opendarwin.org at mitzpettel.com  2006-06-25 10:31 PDT -------
(In reply to comment #7) 
> We should seek out a better name for the non-virtual core
> implementation of updatePseudoChild.

I'll give it more thought.

> In what cases will it ever be good for RenderButton to call doUpdatePseudoChild
> on itself rather than on m_inner?

    button:hover:before { content: 'foo' }

The first time you hover, m_inner is 0.

> Architecturally, the worst thing here is the knowledge in
> RenderContainer::updatePseudoChild that the parent is special when it's a
> RenderButton. That needs a comment at least. And we should see what we can do
> to avoid this new slightly-fragile linkage between the classes. Even having a
> virtual function that was named something cumbersome like
> "updatesPseudoChildForChildren" might be better.

I would just like to mention that there is already one virtual function that
uniquely identifies buttons, and it's called allowsReusingAnonymousChild() :-).

Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list