[webkit-reviews] review granted: [Bug 225088] [GPU Process] [Filters 6/17] Refactor the FilterEffect result buffers into a new class named 'FilterImage' : [Attachment 444902] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 22 20:21:07 PST 2021


Cameron McCormack (:heycam) <heycam at apple.com> has granted Said Abou-Hallawa
<sabouhallawa at apple.com>'s request for review:
Bug 225088: [GPU Process] [Filters 6/17] Refactor the FilterEffect result
buffers into a new class named 'FilterImage'
https://bugs.webkit.org/show_bug.cgi?id=225088

Attachment 444902: Patch

https://bugs.webkit.org/attachment.cgi?id=444902&action=review




--- Comment #29 from Cameron McCormack (:heycam) <heycam at apple.com> ---
Comment on attachment 444902
  --> https://bugs.webkit.org/attachment.cgi?id=444902
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=444902&action=review

> Source/WebCore/ChangeLog:17
> +	   from FilterImage will make this creation happens.

"make this creation happen"

> Source/WebCore/platform/graphics/filters/FilterImage.h:55
> +    void transformToColorSpace(DestinationColorSpace);

The patch has a few functions that take a DestinationColorSpace and some take a
const reference and other pass by value. We should be consistent.

> Source/WebCore/platform/graphics/filters/FilterImage.h:60
> +    RefPtr<ImageBuffer>& imageBufferSlot() { return m_imageBuffer; }

Is it necessary to have a function for this, rather than having the callers
just refer to m_imageBuffer?


More information about the webkit-reviews mailing list