[webkit-reviews] review denied: [Bug 229416] [GTK] Add webkit_web_view_try_close stay event : [Attachment 436225] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 23 12:50:24 PDT 2021


Michael Catanzaro <mcatanzaro at gnome.org> has denied Jan-Michael Brummer
<jan.brummer at tabos.org>'s request for review:
Bug 229416: [GTK] Add webkit_web_view_try_close stay event
https://bugs.webkit.org/show_bug.cgi?id=229416

Attachment 436225: Patch

https://bugs.webkit.org/attachment.cgi?id=436225&action=review




--- Comment #3 from Michael Catanzaro <mcatanzaro at gnome.org> ---
Comment on attachment 436225
  --> https://bugs.webkit.org/attachment.cgi?id=436225
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=436225&action=review

API looks good.

We can bikeshed about the naming. I think I would call it:
WebKitWebView::close-rejected, UIClient::closeRejected,
webkitWebViewCloseRejected. But your naming is fine too. I wonder if others
have suggestions?

r- for now because it needs an API test.

> Source/WebKit/ChangeLog:8
> +	   No new tests (OOPS!).

You'll need to replace this line with an explanation of why the new API is
required.

> Source/WebKit/UIProcess/API/APIUIClient.h:89
> +    virtual void stayOnPage(WebKit::WebPageProxy*) { }

Technically we need an owner to approve this line of the diff, but that
shouldn't be a problem since it's only one line and obviously OK.


More information about the webkit-reviews mailing list