[webkit-reviews] review granted: [Bug 213700] Crash in NetworkProcessProxy::getNetworkProcessConnection() lambda due to missing Optional<> value check : [Attachment 402999] Patch v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 28 13:20:16 PDT 2020


Darin Adler <darin at apple.com> has granted David Kilzer (:ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 213700: Crash in NetworkProcessProxy::getNetworkProcessConnection() lambda
due to missing Optional<> value check
https://bugs.webkit.org/show_bug.cgi?id=213700

Attachment 402999: Patch v1

https://bugs.webkit.org/attachment.cgi?id=402999&action=review




--- Comment #2 from Darin Adler <darin at apple.com> ---
Comment on attachment 402999
  --> https://bugs.webkit.org/attachment.cgi?id=402999
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=402999&action=review

> Source/WebKit/UIProcess/GPU/GPUProcessProxy.cpp:186
> +    sendWithAsyncReply(Messages::GPUProcess::CreateGPUConnectionToWebProcess
{ webProcessProxy.coreProcessIdentifier(), webProcessProxy.sessionID() },
[this, weakThis = makeWeakPtr(*this), reply = WTFMove(reply)](auto&&
optionalConnectionIdentifier) mutable {

I don’t think the renaming is helpful. The code already has * and -> in it
every place this is used, so it’s not like we were overlooking that this was
optional. We were just overlooking that it could actually be null. In fact, I’d
probably rename it to just one word "identifier".

> Source/WebKit/UIProcess/Network/NetworkProcessProxy.cpp:136
> +   
sendWithAsyncReply(Messages::NetworkProcess::CreateNetworkConnectionToWebProces
s { webProcessProxy.coreProcessIdentifier(), webProcessProxy.sessionID() },
[this, weakThis = makeWeakPtr(*this), reply = WTFMove(reply)](auto&&
optionalConnectionIdentifier, auto cookieAcceptPolicy) mutable {

Ditto.


More information about the webkit-reviews mailing list