[webkit-reviews] review granted: [Bug 197833] [JSC] Shrink sizeof(UnlinkedFunctionExecutable) more : [Attachment 369821] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 14 09:06:01 PDT 2019

Darin Adler <darin at apple.com> has granted Yusuke Suzuki <ysuzuki at apple.com>'s
request for review:
Bug 197833: [JSC] Shrink sizeof(UnlinkedFunctionExecutable) more

Attachment 369821: Patch


--- Comment #12 from Darin Adler <darin at apple.com> ---
Comment on attachment 369821
  --> https://bugs.webkit.org/attachment.cgi?id=369821

View in context: https://bugs.webkit.org/attachment.cgi?id=369821&action=review

> Source/JavaScriptCore/ChangeLog:16
> +	   2. We drop m_inferredName and prefer m_ecmaName. The inferred name
is used to offer better function name when the function expression lacks
> +	      the name, but now ECMAScript has a specified semantics to name
those functions with intuitive names. We should use ecmaName consistently,
> +	      and should not eat 8 bytes for inferred names in

Seems like a great strategy, but longer term there has to be something more
elegant than calling this "ECMA name".

More information about the webkit-reviews mailing list