[webkit-reviews] review granted: [Bug 195170] Web Inspector: Debugger: DOM, URL, and Event breakpoints don't grey out when all breakpoints are disabled : [Attachment 363240] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Mar 2 01:23:50 PST 2019


Joseph Pecoraro <joepeck at webkit.org> has granted Devin Rousso
<drousso at apple.com>'s request for review:
Bug 195170: Web Inspector: Debugger: DOM, URL, and Event breakpoints don't grey
out when all breakpoints are disabled
https://bugs.webkit.org/show_bug.cgi?id=195170

Attachment 363240: Patch

https://bugs.webkit.org/attachment.cgi?id=363240&action=review




--- Comment #3 from Joseph Pecoraro <joepeck at webkit.org> ---
Comment on attachment 363240
  --> https://bugs.webkit.org/attachment.cgi?id=363240
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=363240&action=review

r=me

> Source/WebInspectorUI/UserInterface/Controllers/DOMDebuggerManager.js:63
> +		  
this.addDOMBreakpoint(WI.DOMBreakpoint.fromPayload(payload));

Typically we use `fromPayload` when something is coming from a protocol object.
That isn't happening here.

This is the opposite of `breakpoint.serializableInfo` so how about calling
these `FooBreakpoint.deserialize(...)` of `fromCookie` or `fromStorage`?

We have a similar naming convention (deserialize) for objects we serialize
to/form Workers.


More information about the webkit-reviews mailing list