[webkit-reviews] review granted: [Bug 199348] Use separate variables for moving and stationary scrolling relationships in RemoteLayerTreeNode : [Attachment 373195] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 30 13:04:05 PDT 2019


Darin Adler <darin at apple.com> has granted Antti Koivisto <koivisto at iki.fi>'s
request for review:
Bug 199348: Use separate variables for moving and stationary scrolling
relationships in RemoteLayerTreeNode
https://bugs.webkit.org/show_bug.cgi?id=199348

Attachment 373195: patch

https://bugs.webkit.org/attachment.cgi?id=373195&action=review




--- Comment #3 from Darin Adler <darin at apple.com> ---
Comment on attachment 373195
  --> https://bugs.webkit.org/attachment.cgi?id=373195
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=373195&action=review

While I’m not a real expert on this code, this looks good to me.

> Source/WebCore/page/scrolling/ScrollingTree.h:187
> +    HashSet<RefPtr<ScrollingTreeOverflowScrollProxyNode>>
m_activeOverflowScrollProxyNodes;
> +    HashSet<RefPtr<ScrollingTreePositionedNode>> m_activePositionedNodes;

A number of places elsewhere use HashSet<Ref<>> rather than HashSet<RefPtr<>>.
Is there a reason to prefer RefPtr here?

> Source/WebKit/UIProcess/RemoteLayerTree/ios/RemoteLayerTreeViews.mm:134
> +		   return (WKChildScrollView *)actingParent->uiView();

Not new, but: Would be nice to have a type checking cast like downcast<> here
for clarity/assertion. Also unclear to me how solid the guarantee behind this
typecast is.


More information about the webkit-reviews mailing list