[webkit-reviews] review granted: [Bug 195181] cloop.rb shift mask should depend on the word size being shifted. : [Attachment 363250] proposed patch.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 28 12:45:10 PST 2019


Yusuke Suzuki <ysuzuki at apple.com> has granted Mark Lam <mark.lam at apple.com>'s
request for review:
Bug 195181: cloop.rb shift mask should depend on the word size being shifted.
https://bugs.webkit.org/show_bug.cgi?id=195181

Attachment 363250: proposed patch.

https://bugs.webkit.org/attachment.cgi?id=363250&action=review




--- Comment #3 from Yusuke Suzuki <ysuzuki at apple.com> ---
Comment on attachment 363250
  --> https://bugs.webkit.org/attachment.cgi?id=363250
proposed patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=363250&action=review

r=me

> Source/JavaScriptCore/offlineasm/cloop.rb:429
> +    shiftMask = "((sizeof(uintptr_t) == 8) ? 0x3f : 0x1f)" if type == :int
|| type == :uint

Discussed with Mark. The type ":int" and ":uint" actually means "intptr_t" and
"uintptr_t". Then this is correct.
It is nice if we have either of
1. Add a comment about it here now, and rename ":int" => ":intPtr" or something
like that in a subsequent patch.
2. Rename them in this patch too.


More information about the webkit-reviews mailing list