[webkit-reviews] review granted: [Bug 173775] Replace --runtime with something for both ios-simulator and ios-device : [Attachment 315923] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 25 10:38:07 PDT 2017


Aakash Jain <aakash_jain at apple.com> has granted Jonathan Bedard
<jbedard at apple.com>'s request for review:
Bug 173775: Replace --runtime with something for both ios-simulator and
ios-device
https://bugs.webkit.org/show_bug.cgi?id=173775

Attachment 315923: Patch

https://bugs.webkit.org/attachment.cgi?id=315923&action=review




--- Comment #10 from Aakash Jain <aakash_jain at apple.com> ---
Comment on attachment 315923
  --> https://bugs.webkit.org/attachment.cgi?id=315923
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=315923&action=review

> Tools/Scripts/webkitpy/port/ios.py:119
> +	   return True

we can simplify above 4 lines to something like:

return all(part.isdigit() for part in split_by_period)

> Tools/Scripts/webkitpy/port/ios.py:121
> +    def get_option(self, name, default_value=None):

This doesn't exactly validates the input at the time of parsing the arguments,
but should be ok.


More information about the webkit-reviews mailing list