[webkit-reviews] review granted: [Bug 174861] WebDriver: fix return value of close window command : [Attachment 316630] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 3 17:06:51 PDT 2017


Brian Burg <bburg at apple.com> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 174861: WebDriver: fix return value of close window command
https://bugs.webkit.org/show_bug.cgi?id=174861

Attachment 316630: Patch

https://bugs.webkit.org/attachment.cgi?id=316630&action=review




--- Comment #7 from Brian Burg <bburg at apple.com> ---
Comment on attachment 316630
  --> https://bugs.webkit.org/attachment.cgi?id=316630
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=316630&action=review

r=me with naming change

> Source/WebDriver/ChangeLog:24
> +	   (WebDriver::Session::closeWindow): Call
closeTopLevelBrowsingContext() passing the current toplvel browsing context.

Nit: toplvel

> Source/WebDriver/Session.cpp:60
> +void Session::closeNextToplevelBrowsingContext(const String&
toplevelBrowsingContext, Function<void (CommandResult&&)>&& completionHandler)

Shouldn't this entry point be closeAllToplevelBrowsingContexts? It closes more
than just the next one.


More information about the webkit-reviews mailing list