[webkit-reviews] review granted: [Bug 170730] REGRESSION(r215211): [GTK] Several webgl related tests are failing : [Attachment 308238] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 26 06:00:52 PDT 2017


Carlos Garcia Campos <cgarcia at igalia.com> has granted Miguel Gomez
<magomez at igalia.com>'s request for review:
Bug 170730: REGRESSION(r215211): [GTK] Several webgl related tests are failing
https://bugs.webkit.org/show_bug.cgi?id=170730

Attachment 308238: Patch

https://bugs.webkit.org/attachment.cgi?id=308238&action=review




--- Comment #13 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 308238
  --> https://bugs.webkit.org/attachment.cgi?id=308238
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=308238&action=review

Apart from the naming and making it protected, the patch looks good to me, but
I think it's would be better if Said also took a look at it. Thanks!

> Source/WebCore/platform/image-decoders/ImageDecoder.h:71
> +    virtual void decode() = 0;

I think this is a bit confusing, because this actually means decode until you
get the size. So, I would rename it to make it clear this doesn't decode the
whole image. I also assume that this is async, can be called with partial data
and can fail if don't have enough data yet, right? Based on that assumptions I
would call this startDecodingUntilSizeIsAvailable() or
tryDecodingUntilSizeIsAvailable() or something similar. I would also make it
protected, since this is only used inside setData().


More information about the webkit-reviews mailing list