[webkit-reviews] review granted: [Bug 137431] Use is<>() / downcast<>() for CachedResource subclasses : [Attachment 239293] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 5 16:06:11 PDT 2014


Benjamin Poulain <benjamin at webkit.org> has granted Chris Dumez
<cdumez at apple.com>'s request for review:
Bug 137431: Use is<>() / downcast<>() for CachedResource subclasses
https://bugs.webkit.org/show_bug.cgi?id=137431

Attachment 239293: Patch
https://bugs.webkit.org/attachment.cgi?id=239293&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=239293&action=review


> Source/WebCore/loader/cache/CachedResourceLoader.cpp:708
> +	       CachedImage& image = downcast<CachedImage>(*resource);
> +	       image.load(this, defaultCachedResourceOptions());

Darin would probably prefer this on one line. Personally I like the named
temporary here.

Your call.

> Source/WebKit/mac/Misc/WebCache.mm:205
>      if (!cachedResource || !cachedResource->isImage())

Why keep this?


More information about the webkit-reviews mailing list