[webkit-reviews] review granted: [Bug 137429] Use is<>() / downcast<>() for StyleSheet subclasses : [Attachment 239291] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 5 15:54:42 PDT 2014


Benjamin Poulain <benjamin at webkit.org> has granted Chris Dumez
<cdumez at apple.com>'s request for review:
Bug 137429: Use is<>() / downcast<>() for StyleSheet subclasses
https://bugs.webkit.org/show_bug.cgi?id=137429

Attachment 239291: Patch
https://bugs.webkit.org/attachment.cgi?id=239291&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=239291&action=review


> Source/WebCore/dom/DocumentStyleSheetCollection.cpp:411
>      for (unsigned i = 0; i < sheets.size(); ++i) {

Let's update the loop too.

> Source/WebCore/dom/DocumentStyleSheetCollection.cpp:413
> +	   if (!is<CSSStyleSheet>(*sheets[i]))
>	       continue;

I would move this after sheets[i]->disabled() to reduce the span between is<>
and downcast<>, making it easier to follow the flow.


More information about the webkit-reviews mailing list