[webkit-reviews] review granted: [Bug 27684] Hardware accelerated CSS transitions appear pixelated when scaled up using transform : [Attachment 211852] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 17 09:04:53 PDT 2013


Dean Jackson <dino at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 27684: Hardware accelerated CSS transitions appear pixelated when scaled up
using transform
https://bugs.webkit.org/show_bug.cgi?id=27684

Attachment 211852: Patch
https://bugs.webkit.org/attachment.cgi?id=211852&action=review

------- Additional Comments from Dean Jackson <dino at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=211852&action=review


lgtm

> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:258
> +    TransformationMatrix::DecomposedType decomposeData;

At some point in the future, I think we should rename this
TransformationMatrix::DecompositionData or something (Type doesn't make sense)

> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:989
> +TransformationMatrix GraphicsLayerCA::layerTransform(const FloatPoint&
position, const TransformationMatrix* customTransform) const

Is customTransform the right name? customCurrentTransform?

> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:1265
> +    // After committing animations, see if we need to adjust contentScale
accordingly.

Typo: contentsScale

> LayoutTests/compositing/contents-scale/animating.html:17
> +	   -webkit-animation: scale 100000000s infinite linear;

We should ask for "day", "months", "years", "decades", "centuries" CSS units.
Except I think they must be singular, so it would be 10000day. Weird.

>
LayoutTests/platform/mac/compositing/tiling/rotated-tiled-preserve3d-clamped-ex
pected.txt:43
> -			 (tile cache coverage 0, 0 2800 x 300)
> +			 (contentsScale 1.00)
> +			 (tile cache coverage 0, 0 2799 x 299)
>			 (tile size 512 x 512)
> -			 (top left tile 0, 0 tiles grid 6 x 1)
> +			 (top left tile 0, 0 tiles grid 5 x 1)

Why did this change?


More information about the webkit-reviews mailing list