[webkit-reviews] review granted: [Bug 120619] Use OwnPtr in the RenderLayerFilterInfo map : [Attachment 210329] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 3 07:42:20 PDT 2013

Anders Carlsson <andersca at apple.com> has granted Darin Adler
<darin at apple.com>'s request for review:
Bug 120619: Use OwnPtr in the RenderLayerFilterInfo map

Attachment 210329: Patch

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=210329&action=review

I wonder if the optimization to delete the map if it's empty is actually useful

> Source/WebCore/rendering/RenderLayerFilterInfo.cpp:57
> +static OwnPtr<RenderLayerFilterInfoMap>& filterMap()

I wish we had a better name for these types of global smart pointer variable

More information about the webkit-reviews mailing list