[webkit-reviews] review granted: [Bug 116887] Freeze when loading a particular page on washingtonpost.com with NetworkProcess enabled : [Attachment 203093] proposed fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 28 15:07:32 PDT 2013


Darin Adler <darin at apple.com> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 116887: Freeze when loading a particular page on washingtonpost.com with
NetworkProcess enabled
https://bugs.webkit.org/show_bug.cgi?id=116887

Attachment 203093: proposed fix
https://bugs.webkit.org/attachment.cgi?id=203093&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=203093&action=review


r=me, but the patch as-is breaks builds on all non-CF platforms so please do
fix that

> Source/WebCore/platform/KURL.h:29
> +#include "CFURLExtras.h"

This is a platform-specific header file so it should not be included
unconditionally. I think it’s hard to know where to put the URLCharBuffer
typedef. Maybe we can repeat it in both CFURLExtras.h and in KURL.h.

>> Source/WebCore/platform/KURL.h:200
>> +	void copyToBuffer(URLCharBuffer& buffer) const;
> 
> The parameter name "buffer" adds no information, so it should be removed. 
[readability/parameter_name] [5]

I agree with the style bot on this.

> Source/WebCore/platform/cf/CFURLExtras.h:36
> +typedef Vector<char, 512> URLCharBuffer;

This is not CF-specific and needs to be compiled on platform that can’t compile
CFURLRef.

> Source/WebCore/platform/cf/KURLCFNet.cpp:44
> +    // FIXME: Why is it OK to ignore base URL here?

The normal way to deal with this would be to call CFURLCopyAbsoluteURL. I think
the comment should say something more like:

    // FIXME: Should we call CFURLCopyAbsoluteURL here?

> Source/WebCore/platform/mac/KURLMac.mm:62
> +	   // We use the toll-free bridge between NSURL and CFURL to
> +	   // create a CFURLRef supporting both empty and null values.

What does “a CFURLRef supporting both empty and null values” mean?

> Source/WebKit2/Shared/cf/ArgumentCodersCF.cpp:532
> +	   // FIXME: This loses base URL, which seems incorrect.

I would say “discards” rather than “loses”.


More information about the webkit-reviews mailing list