[webkit-reviews] review granted: [Bug 105066] [HTMLTemplateElement] Disallow cycles within template content : [Attachment 181193] Tackle shadow dom too

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 3 12:08:49 PST 2013


Ojan Vafai <ojan at chromium.org> has granted Adam Klein <adamk at chromium.org>'s
request for review:
Bug 105066: [HTMLTemplateElement] Disallow cycles within template content
https://bugs.webkit.org/show_bug.cgi?id=105066

Attachment 181193: Tackle shadow dom too
https://bugs.webkit.org/attachment.cgi?id=181193&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=181193&action=review


> Source/WebCore/dom/ContainerNode.cpp:169
>	   if (newChild->contains(newParent))
>	       return HIERARCHY_REQUEST_ERR;
> +	   if (needsHostElementContainmentCheck(newParent) &&
newChild->containsIncludingHostElements(newParent))

Can we only call the appropriate contains call instead of walking up the tree
twice?

> Source/WebCore/dom/Node.cpp:1078
> +	       node = node->parentOrHostNode();

Seems like we need to rename this to parentOrShadowHostNode. Fine to do so as a
separate patch, but a FIXME as part of this one would be nice.


More information about the webkit-reviews mailing list