[webkit-reviews] review denied: [Bug 119979] REGRESSION(r127163): Respect clearance set on ancestors when placing floats : [Attachment 209029] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 19 13:08:39 PDT 2013


Dave Hyatt <hyatt at apple.com> has denied Robert Hogan <robert at webkit.org>'s
request for review:
Bug 119979: REGRESSION(r127163): Respect clearance set on ancestors when
placing floats
https://bugs.webkit.org/show_bug.cgi?id=119979

Attachment 209029: Patch
https://bugs.webkit.org/attachment.cgi?id=209029&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=209029&action=review


r-

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:2584
> +LayoutUnit
RenderBlock::LineBreaker::marginOffsetForSelfCollapsingBlock(RenderBlock*
child)

This function should be in RenderBlock.cpp and not in the line layout file.

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:2586
> +    while (child) {

child is a bad name for this variable, since you're looping up through parents.
I'd assign to a current variable.

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:2589
> +	   if (child->previousSibling() || !child->parent() ||
!child->parent()->isRenderBlock())

The previousSibling() could be floating or positioned. I think you are wanting
to ask if there is a previous normal flow sibling.


More information about the webkit-reviews mailing list