[webkit-reviews] review granted: [Bug 115138] [ARM] Expand the use of integer division : [Attachment 199891] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 29 17:59:53 PDT 2013


Benjamin Poulain <benjamin at webkit.org> has granted Cosmin Truta
<ctruta at gmail.com>'s request for review:
Bug 115138: [ARM] Expand the use of integer division
https://bugs.webkit.org/show_bug.cgi?id=115138

Attachment 199891: Patch
https://bugs.webkit.org/attachment.cgi?id=199891&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=199891&action=review


Looks reasonable.

Some comments bellow. I would prefer if Filip could double check before you
land.

> Source/JavaScriptCore/ChangeLog:38
> +	   (JSC::DFG::SpeculativeJIT::compileSoftModuloForX86): Added.
> +	   (JSC::DFG::SpeculativeJIT::compileSoftModuloForARM): Added.
> +	   (JSC::DFG::SpeculativeJIT::compileSoftModulo): Split off the X86 and
ARM codegen.

Why not just name them all compileSoftModulo?
That would make the call site simpler.

> Source/JavaScriptCore/dfg/DFGOperations.cpp:1607
> +    div_t quotientAndRemainder = div(a, b);
> +    return quotientAndRemainder.rem;

a % b?


More information about the webkit-reviews mailing list