[webkit-reviews] review canceled: [Bug 100582] Get rid of StyleResolver state related to unknown pseudo-elements. : [Attachment 171056] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 26 18:47:49 PDT 2012


Dimitri Glazkov (Google) <dglazkov at chromium.org> has canceled Dimitri Glazkov
(Google) <dglazkov at chromium.org>'s request for review:
Bug 100582: Get rid of StyleResolver state related to unknown pseudo-elements.
https://bugs.webkit.org/show_bug.cgi?id=100582

Attachment 171056: Patch
https://bugs.webkit.org/attachment.cgi?id=171056&action=review

------- Additional Comments from Dimitri Glazkov (Google)
<dglazkov at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=171056&action=review


>> Source/WebCore/css/StyleResolver.h:364
>> +	bool checkSelector(const RuleData&, const ContainerNode* scope,
RuleApplicability);
> 
> Should this default to CanBeAnything? (Which is a confusing name, btw.)
> 
> Maybe these should be RestrictToUnknownPseudoElements, NoRestrictions?
> 
> I"m not fully sure what this does to provide better naming help...

Sure, I'd love naming help:

CanBeAnything --> there are no restrictions in this TreeScope (which is like a
little document-type subtree -- think Shadow DOM subtree), the rule can just do
normal matching
NeedsUnknownPseudoElement --> this rule is very likely _not_ to match, because
it's probably in a different TreeScope, but just in case it contains an unknown
pseudo-element, it _could_ match, so we have to check the full selector.

Does this make a bit more sense?


More information about the webkit-reviews mailing list