[webkit-reviews] review denied: [Bug 83012] Web Inspector: localStorage items are not updated when the storage changes : [Attachment 142314] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 17 07:44:35 PDT 2012


Pavel Feldman <pfeldman at chromium.org> has denied Vivek Galatage
<vivekgalatage at gmail.com>'s request for review:
Bug 83012: Web Inspector: localStorage items are not updated when the storage
changes
https://bugs.webkit.org/show_bug.cgi?id=83012

Attachment 142314: Patch
https://bugs.webkit.org/attachment.cgi?id=142314&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=142314&action=review


Some dead code to remove and it is good to go.

> Source/WebCore/inspector/InspectorDOMStorageAgent.h:74
> +    String storageIdForSecurityOrigin(SecurityOrigin*, bool isLocalStorage);


Rename to storageId ?

> Source/WebCore/inspector/InspectorDOMStorageResource.h:57
> +    bool isSameHostAndType(Frame*, bool isLocalStorage) const;

This is now not used.

> Source/WebCore/inspector/InspectorDOMStorageResource.h:58
> +    bool isSameHostAndTypeForSecurityOrigin(SecurityOrigin*, bool
isLocalStorage) const;

Nit: this can now have a better name (isSameHostAndType).

> Source/WebCore/inspector/InspectorDOMStorageResource.h:61
> +    Frame* frame() const { return m_frame.get(); }

You don't need this now.

> Source/WebCore/inspector/InspectorDOMStorageResource.h:69
> +    RefPtr<Frame> m_frame;

You don't need this now.


More information about the webkit-reviews mailing list