[webkit-reviews] review granted: [Bug 76834] Relative pos. input fields in columns vanish when you start typing in them : [Attachment 146699] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 11 09:06:42 PDT 2012


Julien Chaffraix <jchaffraix at webkit.org> has granted Pravin D
<pravind.2k4 at gmail.com>'s request for review:
Bug 76834: Relative pos. input fields in columns vanish when you start typing
in them
https://bugs.webkit.org/show_bug.cgi?id=76834

Attachment 146699: Patch
https://bugs.webkit.org/attachment.cgi?id=146699&action=review

------- Additional Comments from Julien Chaffraix <jchaffraix at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=146699&action=review


> Source/WebCore/page/FrameView.cpp:125
> +static RenderLayer::UpdateLayerPositionsFlags
updateLayerPositionsFlagsForLayer(RenderLayer* layer, bool subtreeRelayout,
bool fullRepaint)

Not a huge fan of updateLayerPositionsFlagsForLayer, alternative names:
flagsForUpdateLayerPosition, updateLayerPositionFlags. I would pick the second
as it's shorter.

Note that WebKit style guide says that boolean should have a verb in them so
the naming could be enhanced:
* I would rename |fullRepaint| to |didFullRepaint| for completeness
* |subtreeRelayout| -> isRelayoutingSubtree, isLayoutingSubtree,
didSubtreeRelayout

> Source/WebCore/page/FrameView.cpp:130
> +    if (subtreeRelayout && layer && layer->isPaginated())

layer cannot be NULL.


More information about the webkit-reviews mailing list