[webkit-reviews] review granted: [Bug 90536] XHR.send should support ArrayBufferView : [Attachment 150748] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 4 08:41:15 PDT 2012


Kenneth Russell <kbr at google.com> has granted Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 90536: XHR.send should support ArrayBufferView
https://bugs.webkit.org/show_bug.cgi?id=90536

Attachment 150748: Patch
https://bugs.webkit.org/attachment.cgi?id=150748&action=review

------- Additional Comments from Kenneth Russell <kbr at google.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=150748&action=review


Looks good overall. A couple of minor comments which you can fix upon landing.
r=me

> Source/WebCore/xml/XMLHttpRequest.cpp:661
> +   
HistogramSupport::histogramEnumeration("WebCore.XHR.send.ArrayBufferView",
XMLHttpRequestSendArrayBuffer, XMLHttpRequestSendArrayBufferEnumMax);

The naming of this histogram is a little confusing. Consider naming it
something like send.ArrayBufferOrView, here and below.

> Source/WebCore/xml/XMLHttpRequest.cpp:686
> +    }

This code is essentially duplicated; please consider factoring it and the body
of send(ArrayBuffer, ...) into a helper method taking (void*, unsigned) as
arguments.


More information about the webkit-reviews mailing list