[webkit-reviews] review granted: [Bug 79499] [GTK] Add support for nested event loops in RunLoop : [Attachment 129009] Patch Proposal

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 27 08:49:19 PST 2012


Martin Robinson <mrobinson at webkit.org> has granted Mario Sanchez Prada
<msanchez at igalia.com>'s request for review:
Bug 79499: [GTK] Add support for nested event loops in RunLoop
https://bugs.webkit.org/show_bug.cgi?id=79499

Attachment 129009: Patch Proposal
https://bugs.webkit.org/attachment.cgi?id=129009&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=129009&action=review


With a one small fix and a rename, this looks good to me.

> Source/WebCore/platform/gtk/RunLoopGtk.cpp:54
> +    for (size_t i = 0; i < m_runLoopMainLoops.size(); ++i) {
> +	   if (!g_main_loop_is_running(m_runLoopMainLoops[i].get()))
> +	       continue;
> +	   g_main_loop_quit(m_runLoopMainLoops[i].get());
> +    }

You should probably traverse the list backward since if a loop > 1 is running,
the ones before it are running too.

> Source/WebCore/platform/gtk/RunLoopGtk.cpp:75
> +GMainLoop* RunLoop::rootMainLoop()

I think I prefer the name innermostRunLoop. Would you mind changing this before
landing.


More information about the webkit-reviews mailing list