[webkit-reviews] review granted: [Bug 68839] De-virtualize JSCell::visitChildrenVirtual and remove all other visitChildrenVirtual methods : [Attachment 109042] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 28 14:28:53 PDT 2011


Darin Adler <darin at apple.com> has granted Mark Hahnenberg
<mhahnenberg at apple.com>'s request for review:
Bug 68839: De-virtualize JSCell::visitChildrenVirtual and remove all other
visitChildrenVirtual methods
https://bugs.webkit.org/show_bug.cgi?id=68839

Attachment 109042: Patch
https://bugs.webkit.org/attachment.cgi?id=109042&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=109042&action=review


> Source/JavaScriptCore/runtime/JSCell.h:89
> +	   void visitChildrenVirtual(SlotVisitor&);

This function name is now not great. I suggest just inlining the logic at the
call site, as I suggested before. Or renaming this. I don’t think we should use
“virtual” to mean “dispatch through the structure method table” since it has a
specific C++ meaning already.


More information about the webkit-reviews mailing list