[webkit-reviews] review denied: [Bug 66323] Rename FontGtk.cpp to FontPango.cpp : [Attachment 106506] Add replacement functions for gdk ones.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 8 16:07:29 PDT 2011


Martin Robinson <mrobinson at webkit.org> has denied Rafael Antognolli
<antognolli at profusion.mobi>'s request for review:
Bug 66323: Rename FontGtk.cpp to FontPango.cpp
https://bugs.webkit.org/show_bug.cgi?id=66323

Attachment 106506: Add replacement functions for gdk ones.
https://bugs.webkit.org/attachment.cgi?id=106506&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=106506&action=review


> Source/WebCore/platform/graphics/cairo/CairoUtilities.cpp:89
> +    const int nBoxes = cairo_region_num_rectangles(region);

nBoxes -> rectCount?

> Source/WebCore/platform/graphics/cairo/CairoUtilities.cpp:94
> +	   cairo_rectangle_int_t box;
> +	   cairo_region_get_rectangle(region, i, &box);
> +	   cairo_rectangle(to, box.x, box.y, box.width, box.height);
> +    }

box -> rect?

> Source/WebCore/platform/graphics/pango/PangoUtilities.cpp:32
> +static cairo_region_t* getLineClipRegionFromLayoutIter(PangoLayoutIter
*iter, int xOrigin, int yOrigin, const int *indexRanges, int nRanges)

The asterisk on indexRanges should be on the type name.

> Source/WebCore/platform/graphics/pango/PangoUtilities.cpp:43
> +	   int nPixelRanges = 0;

nPixelRange -> pixelRangeCount.

> Source/WebCore/platform/graphics/pango/PangoUtilities.cpp:71
> +cairo_region_t* getClipRegionFromPangoLayoutLine(PangoLayoutLine* line, int
xOrigin, int yOrigin, const int* indexRanges, int nRanges)

Instead of two variables to get the origin, I suggest using a const IntPoint&.
It looks like the origin is always 0, 0? Perhaps just ditch the parameters
altogether. nRanges -> rangeCount. Please try to avoid not-well-known
abbreviations.

> Source/WebCore/platform/graphics/pango/PangoUtilities.h:31
> +cairo_region_t* getClipRegionFromPangoLayoutLine(PangoLayoutLine*, int, int,
const int*, int);

You need the variable names here for generic types (int and int*).


More information about the webkit-reviews mailing list