[webkit-reviews] review granted: [Bug 70572] Refactor OptionsObject.cpp : [Attachment 111890] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 26 09:45:10 PDT 2011


Adam Barth <abarth at webkit.org> has granted Kentaro Hara
<haraken at chromium.org>'s request for review:
Bug 70572: Refactor OptionsObject.cpp
https://bugs.webkit.org/show_bug.cgi?id=70572

Attachment 111890: Patch
https://bugs.webkit.org/attachment.cgi?id=111890&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=111890&action=review


> Source/WebCore/bindings/v8/OptionsObject.h:54
> +    bool getKeyValue(const String&, bool&) const;
> +    bool getKeyValue(const String&, int32_t&) const;
> +    bool getKeyValue(const String&, double&) const;
> +    bool getKeyValue(const String&, String&) const;
> +    bool getKeyValue(const String&, ScriptValue&) const;

Why not just call these functions "get" ?

> Source/WebCore/bindings/v8/OptionsObject.h:61
> +    bool getKeyValueWithUndefinedOrNullCheck(const String&, String&) const;

getWithUndefinedOrNullCheck ?


More information about the webkit-reviews mailing list