[webkit-reviews] review denied: [Bug 70688] [chromium] Manage webkit_unit_tests TestSuite lifetime explicitly in DLL build : [Attachment 112103] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 24 10:22:55 PDT 2011


Tony Chang <tony at chromium.org> has denied Nat Duca <nduca at chromium.org>'s
request for review:
Bug 70688: [chromium] Manage webkit_unit_tests TestSuite lifetime explicitly in
DLL build
https://bugs.webkit.org/show_bug.cgi?id=70688

Attachment 112103: Patch
https://bugs.webkit.org/attachment.cgi?id=112103&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=112103&action=review


> Source/WebKit/chromium/tests/RunAllTests.cpp:47
> +// and run inside awebkit.dll.

Nit: awebkit typo

> Source/WebKit/chromium/tests/WebUnitTests.cpp:38
> +namespace {
> +static TestSuite* testSuite = 0;

Nit: No namespace (it's redundant with static and WebKit style prefers static).


>> Source/WebKit/chromium/tests/WebUnitTests.h:46
>> +WEBKIT_EXPORT void InitTestSuite(int argc, char** argv);
> 
> WEBKIT_EXPORT should only appear in the chromium public directory. 
[readability/webkit_export] [5]

We could add a WEBKIT_EXPORT_PRIVATE for these.  See src/net/base/net_export.h
for an example of this.


More information about the webkit-reviews mailing list