[webkit-reviews] review granted: [Bug 69056] Check behavior of tabindex attribute with a large number : [Attachment 109444] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 16 05:33:34 PDT 2011


Daniel Bates <dbates at webkit.org> has granted Kent Tamura <tkent at chromium.org>'s
request for review:
Bug 69056: Check behavior of tabindex attribute with a large number
https://bugs.webkit.org/show_bug.cgi?id=69056

Attachment 109444: Patch
https://bugs.webkit.org/attachment.cgi?id=109444&action=review

------- Additional Comments from Daniel Bates <dbates at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=109444&action=review


> LayoutTests/fast/dom/tabindex-defaults.html:11
> +<div id="console"></div>
> +
> +<div id=container>

Nit: This patch is inconsistent in its use of quotes around attribute values. I
suggest picking one style for consistency. For example, on line 9 you put
quotes around the attribute value of id, but on line 10 you don't. Similar
inconsistencies can be seen in the rest of the HTML markup in this file.

> LayoutTests/fast/dom/tabindex-defaults.html:31
> +var anchor = document.getElementById('a1');
> +var button = document.getElementById('b1');
> +var input = document.getElementById('i1');
> +var select = document.getElementById('s1');
> +var textarea = document.getElementById('t1');
> +var editableDiv = document.getElementById('e1');
> +var normalDiv = document.getElementById('u1');

This is fine as-is. For your consideration, I suggest renaming the ids of the
elements to match these variable names. That is, rename "a1" to "anchor",
rename "b1" to "button", and so forth.


More information about the webkit-reviews mailing list