[webkit-reviews] review denied: [Bug 69870] [Chromium] Empty API for web intents : [Attachment 115418] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 18 11:08:53 PST 2011


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Greg Billock
<gbillock at google.com>'s request for review:
Bug 69870: [Chromium] Empty API for web intents
https://bugs.webkit.org/show_bug.cgi?id=69870

Attachment 115418: Patch
https://bugs.webkit.org/attachment.cgi?id=115418&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=115418&action=review


> Source/WebKit/chromium/public/WebFrame.h:556
> +    virtual void replyFromIntentService(WebIntentsReplyType, const
WebString&, int intentId) = 0;

How about calling this "handleIntentResult" or "handleIntentReply"?

> Source/WebKit/chromium/public/WebIntentServiceData.h:48
> +class WebIntentServiceData {

nit: "Info" might be a better suffix for this class.  See for example
WebPopupMenuInfo.

> Source/WebKit/chromium/public/WebIntentServiceData.h:53
> +    WEBKIT_EXPORT void setUrl(const WebURL&);

nit: setUrl should be setURL per the style guide


More information about the webkit-reviews mailing list