[webkit-reviews] review denied: [Bug 53173] Web Inspector: [Chromium] Landing detailed heap snapshots, part 1 : [Attachment 80645] rebased

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 31 09:07:14 PST 2011


Pavel Feldman <pfeldman at chromium.org> has denied Mikhail Naganov
<mnaganov at chromium.org>'s request for review:
Bug 53173: Web Inspector: [Chromium] Landing detailed heap snapshots, part 1
https://bugs.webkit.org/show_bug.cgi?id=53173

Attachment 80645: rebased
https://bugs.webkit.org/attachment.cgi?id=80645&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=80645&action=review

> Source/WebCore/ChangeLog:5
> +	   Web Inspector: [Chromium] Landing detailed heap snapshots, part 1.

ChangeLog structure should be:
Web Inspector: <foo>
http:// bug

Detailed description.

...

> Source/WebCore/ChangeLog:19
> +	   (WebInspector.HeapSnapshotEdgeWrapper):

No need to enumerate all the new methods.

> Source/WebCore/inspector/front-end/HeapSnapshot.js:50
> +WebInspector.RetainersSlice = function(snapshot, start, end)

NodesSlive and RetainersSlice can inherit from single class.

> Source/WebCore/inspector/front-end/HeapSnapshot.js:76
> +WebInspector.HeapSnapshotEdgeWrapper.prototype = {

I like iterator name better.

> Source/WebCore/inspector/front-end/HeapSnapshot.js:77
> +    becomeFirst: function()

reset: function

> Source/WebCore/inspector/front-end/HeapSnapshot.js:82
> +    becomeNext: function()

next: function()

> Source/WebCore/inspector/front-end/HeapSnapshot.js:92
> +    get count()

length

> Source/WebCore/inspector/front-end/HeapSnapshot.js:102
> +    get hasNext()

hasNext: function()

> Source/WebCore/inspector/front-end/HeapSnapshot.js:184
> +	   return "???";

Should this string be localized?

> Source/WebCore/inspector/front-end/HeapSnapshot.js:221
> +    becomeDominator: function()

ditto to the naming.


More information about the webkit-reviews mailing list