[webkit-reviews] review granted: [Bug 53122] Change HTMLInputElement-derived parts of media element shadow DOM to use shadowPseudoId. : [Attachment 80115] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 25 14:06:13 PST 2011


Darin Adler <darin at apple.com> has granted Dimitri Glazkov (Google)
<dglazkov at chromium.org>'s request for review:
Bug 53122: Change HTMLInputElement-derived parts of media element shadow DOM to
use shadowPseudoId.
https://bugs.webkit.org/show_bug.cgi?id=53122

Attachment 80115: Patch
https://bugs.webkit.org/attachment.cgi?id=80115&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=80115&action=review

Seems unfortunate that shadowPseudoId returns an AtomicString so has to thrash
reference counts. Is there any caller that can’t return const AtomicString&
instead? Might be nice to tighten that up again.

> Source/WebCore/rendering/MediaControlElements.cpp:468
> +    m_displayType = MediaMuteButton;

Why isn’t this a MediaControlInputElement constructor argument? It seems less
than optimal to set this field in a base class directly instead of letting the
constructor do it.


More information about the webkit-reviews mailing list