[webkit-reviews] review granted: [Bug 45657] Web Inspector: [Resources panel]=?UTF-8?Q?=20Need=20more=20visible=20=E2=80=9Cat=20a=20glance=E2=80=9D?=. : [Attachment 69068] [PATCH] New panel behind the flag. Screenshots to follow.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 28 10:44:36 PDT 2010


Timothy Hatcher <timothy at apple.com> has granted Pavel Feldman
<pfeldman at chromium.org>'s request for review:
Bug 45657: Web Inspector: [Resources panel] Need more visible “at a glance”.
https://bugs.webkit.org/show_bug.cgi?id=45657

Attachment 69068: [PATCH] New panel behind the flag. Screenshots to follow.
https://bugs.webkit.org/attachment.cgi?id=69068&action=review

------- Additional Comments from Timothy Hatcher <timothy at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=69068&action=review

> WebCore/WebCore.vcproj/WebCore.vcproj:52787
> +				       
RelativePath="..\inspector\front-end\network.css"

NetworkPanel.css is a better name I think.

> WebCore/inspector/front-end/DataGrid.js:539
> +	   function comparatorWrapper(trA, trB)

Just use a and b.

> WebCore/inspector/front-end/NetworkPanel.js:64
> +	   return [ this._largerResourcesButton.element,
this._clearButton.element ];

No spaces after [ and before ].

> WebCore/inspector/front-end/NetworkPanel.js:74
> +	   return [ this.containerElement ];

No spaces after [ and before ].

> WebCore/inspector/front-end/NetworkPanel.js:96
> +	   var columns = { url: {}, method: {}, status: {}, type: {}, size: {},
time: {}, timeline: {} };

No spaces after { and before }.

> WebCore/inspector/front-end/NetworkPanel.js:204
> +	   if (this.calculator.startAtZero ||
!this.calculator.computePercentageFromEventTime) {

Does this code path even apply to the Network panel now?

> WebCore/inspector/front-end/NetworkPanel.js:439
> +	   for (var i = 0; i < staleItemsLength; ++i) {

No braces.

> WebCore/inspector/front-end/NetworkPanel.js:515
> +//	     if (!this.currentQuery && resource._resourceGridNode)

Don't usually land commented code.

> WebCore/inspector/front-end/NetworkPanel.js:531
> +//	       if (!this.currentQuery && resource._resourceGridNode)

Don't usually land commented code.

> WebCore/inspector/front-end/NetworkPanel.js:725
> +	   if (resource.timing.dnsStart !== -1) {

No braces.


More information about the webkit-reviews mailing list