[webkit-reviews] review granted: [Bug 45466] [WINCE] Replace codePage instead of TextEncoding : [Attachment 67052] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 14 08:42:56 PDT 2010


Adam Roben (aroben) <aroben at apple.com> has granted Patrick R. Gansterer
<paroga at paroga.com>'s request for review:
Bug 45466: [WINCE] Replace codePage instead of TextEncoding
https://bugs.webkit.org/show_bug.cgi?id=45466

Attachment 67052: Patch
https://bugs.webkit.org/attachment.cgi?id=67052&action=review

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
View in context:
https://bugs.webkit.org/attachment.cgi?id=67052&action=prettypatch

> WebCore/ChangeLog:8
> +	   Use codePage as member variable to aviod repeated lookup.
Typo: aviod

> WebCore/platform/text/wince/TextCodecWinCE.cpp:136
> -    return new TextCodecWinCE(encoding);
> +    return new TextCodecWinCE(getCodePage(encoding.name()));
Another option would have been to put the call to getCodePage inside the
TextCodecWinCE constructor. It isn't clear to me whether that approach would be
better.


More information about the webkit-reviews mailing list