[webkit-reviews] review denied: [Bug 49705] [HTML5] Rename member variables of HTMLScriptElement : [Attachment 74189] renamed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 17 22:11:18 PST 2010


Darin Adler <darin at apple.com> has denied Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 49705: [HTML5] Rename member variables of HTMLScriptElement
https://bugs.webkit.org/show_bug.cgi?id=49705

Attachment 74189: renamed
https://bugs.webkit.org/attachment.cgi?id=74189&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=74189&action=review

> WebCore/dom/ScriptElement.h:92
> +    bool m_insertedByParser;
> +    bool m_extrnalScript;
> +    bool m_alreadyStarted;
>      bool m_firedLoad;

Boolean data members should be named so that they finish a sentence "script
element <xxx>". That’s why they often start with something like “was”.

I suggest:

    m_wasInsertedByParser
    m_isExternalScript
    m_wasAlreadyStarted
    m_hasFiredLoadEvent

I also suggest renaming functions, not just the data members.

"extrnalScript" needs an "e".


More information about the webkit-reviews mailing list