[webkit-reviews] review granted: [Bug 37909] Call sites of TextIterator constructor are difficult to read : [Attachment 53919] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 21 09:34:40 PDT 2010


Darin Adler <darin at apple.com> has granted Shinichiro Hamaji
<hamaji at chromium.org>'s request for review:
Bug 37909: Call sites of TextIterator constructor are difficult to read
https://bugs.webkit.org/show_bug.cgi?id=37909

Attachment 53919: Patch v2
https://bugs.webkit.org/attachment.cgi?id=53919&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
>  enum TextIteratorBehavior {
>      TextIteratorBehaviorDefault = 0,
> -    TextIteratorBehaviorEmitCharactersBetweenAllVisiblePositions = 1 << 0,
> -    TextIteratorBehaviorEnterTextControls = 1 << 1,
> +    TextIteratorBehaviorEmitsCharactersBetweenAllVisiblePositions = 1 << 0,
> +    TextIteratorBehaviorEntersTextControls = 1 << 1,
>      TextIteratorBehaviorEmitsTextsWithoutTranscoding = 1 << 2,
>  };

I think these repeat the word "Behavior" too much. I would call these:

    TextIteratorDefaultBehavior = 0,
    TextIteratorEmitsCharactersBetweenAllVisiblePositions = 1 << 0,
    TextIteratorEntersTextControls = 1 << 1,
    TextIteratorEmitsTextWithoutTranscoding = 1 << 2,

r=me, whether or not you change the names


More information about the webkit-reviews mailing list