[webkit-reviews] review requested: [Bug 23601] DOMSelection.getRangeAt() returns a different range than the selection : [Attachment 27373] Rename toRange to toNormalizedRange and add new firstRange which returns an unmodified range

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 5 18:00:30 PST 2009


Eric Seidel <eric at webkit.org> has asked  for review:
Bug 23601: DOMSelection.getRangeAt() returns a different range than the
selection
https://bugs.webkit.org/show_bug.cgi?id=23601

Attachment 27373: Rename toRange to toNormalizedRange and add new firstRange
which returns an unmodified range
https://bugs.webkit.org/attachment.cgi?id=27373&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
 LayoutTests/ChangeLog				    |	13 ++++
 LayoutTests/fast/dom/Selection/getRangeAt.html     |	13 ++++
 .../fast/dom/Selection/resources/TEMPLATE.html     |	13 ++++
 .../fast/dom/Selection/resources/getRangeAt.js     |	33 +++++++++
 WebCore/ChangeLog				    |	77 ++++++++++++++++++++
 WebCore/WebCore.base.exp			    |	 2 +-
 WebCore/dom/InputElement.cpp			    |	 2 +-
 WebCore/editing/DeleteButtonController.cpp	    |	 2 +-
 WebCore/editing/Editor.cpp			    |	24 +++---
 WebCore/editing/EditorCommand.cpp		    |	 8 +-
 WebCore/editing/RemoveFormatCommand.cpp	    |	 2 +-
 WebCore/editing/ReplaceSelectionCommand.cpp	    |	 4 +-
 WebCore/editing/Selection.cpp			    |	25 +++----
 WebCore/editing/Selection.h			    |	 8 ++-
 WebCore/editing/SelectionController.h		    |	 2 +-
 WebCore/editing/TypingCommand.cpp		    |	 4 +-
 WebCore/editing/markup.cpp			    |	 2 +-
 WebCore/loader/archive/cf/LegacyWebArchive.cpp     |	 2 +-
 WebCore/page/AccessibilityRenderObject.cpp	    |	 2 +-
 WebCore/page/ContextMenuController.cpp 	    |	 4 +-
 WebCore/page/DOMSelection.cpp			    |	13 ++--
 WebCore/page/DragController.cpp		    |	 8 +-
 WebCore/page/EventHandler.cpp			    |	 2 +-
 WebCore/page/Frame.cpp 			    |	16 ++--
 WebCore/platform/ContextMenu.cpp		    |	 2 +-
 WebKit/mac/ChangeLog				    |	22 ++++++
 WebKit/mac/WebView/WebFrame.mm 		    |	 8 +-
 WebKit/mac/WebView/WebHTMLView.mm		    |	 6 +-
 WebKit/mac/WebView/WebView.mm			    |	 4 +-
 29 files changed, 250 insertions(+), 73 deletions(-)


More information about the webkit-reviews mailing list