[webkit-reviews] review granted: [Bug 32387] Accelerated transitions broken when mixed with paused animations : [Attachment 44638] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 11 11:48:14 PST 2009


mitz at webkit.org has granted Simon Fraser (smfr) <simon.fraser at apple.com>'s
request for review:
Bug 32387: Accelerated transitions broken when mixed with paused animations
https://bugs.webkit.org/show_bug.cgi?id=32387

Attachment 44638: Patch
https://bugs.webkit.org/attachment.cgi?id=44638&action=review

------- Additional Comments from mitz at webkit.org
>		       m_startTime = param;
> -
> +		   
>		   // Decide whether to go into looping or ending state

Extra whitespace added there.

> -void KeyframeAnimation::endAnimation(bool reset)
> +void KeyframeAnimation::pauseAnimation(double timeOffset)
>  {
> -    if (m_object) {
> +    if (!m_object)
> +	   return;
> +
> +    fprintf(stderr, "pausing animation, offset %f\n", timeOffset);

Please remove the fprintf.

> +    struct AnimationProcessingInfo {
> +	   AnimationProcessingInfo(AnimationProcessingAction action = Remove,
double timeOffset = 0)
> +	       : action(action)
> +	       , timeOffset(timeOffset) { }

The braces should go each on its own separate line:
	   {
	   }

Perhaps the struct should be called AnimationProcessingAction and the enum
renamed to something else? Perhaps not.


More information about the webkit-reviews mailing list