[webkit-reviews] review requested: [Bug 28036] [Qt] Public API to configure the storage path for HTML5 localStorage : [Attachment 34537] 3rd try

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 10 20:12:02 PDT 2009

Laszlo Gombos <laszlo.1.gombos at nokia.com> has asked  for review:
Bug 28036: [Qt] Public API to configure the storage path for HTML5 localStorage

Attachment 34537: 3rd try

------- Additional Comments from Laszlo Gombos <laszlo.1.gombos at nokia.com>
Additional changes in the 3rd revision of the patch:
 - LocalStorageDatabaseEnabled enum value is now deprecated, the new name is
 - LocalStoragePath now has a default (<base path>/LocalStorage/)

Here are some reasons to keep the LocalStorage name (instead of switching to
 - The LocalStorageEnabled setting does not control SessionStorage and as such
WebStorageEnabled name would be misleading
 - WebStorage is indeed the name of the specification, but the relevant JS
interface is called window.localStrorage - I believe the JS interface name is
equally/more relevant 
 - WebStorage spec is referenced not only in the HTML5 spec but also in Widgets
APIs and Events spec (see http://www.w3.org/TR/widgets-apis,
widget.preferences). Since the interface that is defined in this patch is only
for the HTML5 LocalStorage I think the name of the interface should be also
specific to HTML5 to distinguish it from other WebStorage use-cases

More information about the webkit-reviews mailing list